Sorry, misunderstood your question and thought you had a special naming scheme set up.
If I understood you correctly now, you could do something like this:
Skin skin = <assign your skin here, however you want to access it>;
var attachmentsInSkin = skin.GetAttachments();
string slotName = attachmentsInSkin.Count > 0 ? skeleton.Slots.Items[attachmentsInSkin[0].SlotIndex].data.name : "no slots in skin";
DCalabrese :the Slot that a Skin is located in.
What you are trying to do seems against the normal way how you would organize stuff. A skin contains attachments that are assigned to slots, it is not skins that are part of a slot.
I don't know your setup well enough, but it is in general considered good design to have the application logic manage it's state of assignment at a specialized module (at e.g. a graphics module) instead of performing manipulations and then querying what it just has done.