sanaruSeeBe

unity项目里使用的是3.8版本的Spine-unity(upm),然后我们使用最新的4.1.17版spine编辑器制作了多个动画,在导出时选择的3.8版本的json文件,经测试一部分文件可以顺利的导入进unity里使用,有一个动画文件导入后提示错误:
Error reading skeleton JSON file for SkeletonData asset: 123_SkeletonData
Requested value 'proportional' was not found.

之后我们展开了调查,发现将路径功能删掉后可以继续使用此文件,但是路径功能我们想要使用,请问应该如何处理。
sanaruSeeBe
  • 帖子: 3

Misaki

你是说你从Spine 4.1导出骨架时,将导出设置中的 版本选项设为3.8?
Are you saying that you are exporting the skeleton from Spine 4.1 with the export settings set to the Version option to 3.8?
Version.png

如果是这样,请注意,导出的数据在spine-unity运行时3.8下将无法正常加载。版本选项用于导出可以被旧版本的Spine编辑器加载的数据。它不提供可用于旧版Spine运行系统的数据。
If so, note that the exported data will not load properly with the spine-unity runtime 3.8. The Version option is used to export data that can be loaded by an older version of the Spine editor. It does not give data that can be used with an older Spine runtimes version.

如果你想保留运行时版本,你需要将该Spine项目降级到3.8。反之,如果你想保持你的Spine项目版本为4.1,你需要升级运行时版本。运行时的升级指南可以在这里找到。
If you want to keep the runtime version, you need to downgrade that Spine project to 3.8. Conversely, if you want to keep your Spine project version as 4.1, you need to upgrade the runtime version. The runtime upgrade guides can be found here:
[ZH-CN]Spine-Unity 3.8 to 4.0升级指南
[ZH-CN]Spine-Unity 4.0 to 4.1升级指南
您没有权限查看这个主题的附件。
头像
Misaki

Misaki
  • 帖子: 1040

sanaruSeeBe

Misaki 写道:你是说你从Spine 4.1导出骨架时,将导出设置中的 版本选项设为3.8?
Are you saying that you are exporting the skeleton from Spine 4.1 with the export settings set to the Version option to 3.8?
如果是这样,请注意,导出的数据在spine-unity运行时3.8下将无法正常加载。版本选项用于导出可以被旧版本的Spine编辑器加载的数据。它不提供可用于旧版Spine运行系统的数据。
If so, note that the exported data will not load properly with the spine-unity runtime 3.8. The Version option is used to export data that can be loaded by an older version of the Spine editor. It does not give data that can be used with an older Spine runtimes version.
如果你想保留运行时版本,你需要将该Spine项目降级到3.8。反之,如果你想保持你的Spine项目版本为4.1,你需要升级运行时版本。运行时的升级指南可以在这里找到。
If you want to keep the runtime version, you need to downgrade that Spine project to 3.8. Conversely, if you want to keep your Spine project version as 4.1, you need to upgrade the runtime version. The runtime upgrade guides can be found here:
http://esotericsoftware.com/forum/ZH-CN-Spine-Unity-3-8-to-4-0-16688
http://esotericsoftware.com/forum/ZH-CN-Spine-Unity-4-0-to-4-1-17702
已经解决了,在动画制作时,将间距模式调整成了“比例”,导致发布出来的json无法被解析。我们将模式调整回百分比后,4.117发布的3.8文件可以正常导入到unity的项目里。
sanaruSeeBe
  • 帖子: 3

Harald

请注意,虽然这可能适用于您当前的资产,但运行时不支持从 Spine Editor 版本 4.1 导出的版本设置为“3.8”的 json 资产,并且将来可能无法正确读取。 如果您遇到任何其他问题,请查看上面 Misaki 的帖子,了解如何正确解决此问题。
Please note that while this might work with your current assets, exported json assets with version set to 3.8 from Spine Editor version 4.1 are not supported by the runtimes and may fail to read correctly in the future. If you run into any other issues, please check out the posting by Misaki above to see how to properly resolve this.
头像
Harald

Harri
  • 帖子: 4341


回到 中国Spine用户