ccwccy

使用的引擎是cocos,升级到4.0之后 项目原先的旧版本导出的.skel二进制文件读取会报错。
请问有没有工具可以把旧版本.skel转换成高版本运行库可以运行呢

项目中使用的spine资源很多,也可以一个个重新用高版本导出,就是担心会有遗漏的
您没有权限查看这个主题的附件。
ccwccy
  • 帖子: 2

Nate

Sorry for the late response. To use 4.0 runtimes you'll need to export your data with the 4.0 editor. You can use your same atlas files, you only need the 4.0 JSON or binary data.
对不起,回复得太晚了。要使用4.0运行时间,你需要用4.0编辑器导出你的数据。你可以使用你相同的图集文件,你只需要4.0的JSON或二进制数据。

If you have many Spine projects, you use the command line:
如果你有很多Spine项目,你使用命令行。
Command line interface - Spine User Guide

If you have the Spine project files with one of these:
如果你有Spine项目的文件,有这样的文件。
spine -u 4.0.xx -i example.project -o /path/to/output --export json
spine -u 4.0.xx -i example.project -o /path/to/output --export binary
If you do not have Spine project files, you need to import into the old version to create a project file:
如果你没有Spine项目文件,你需要导入旧版本创建项目文件。
spine -u 3.6.53 -i example.json -o example.spine --import
I don't remember if 3.6 can import from the command line. It is very old. If the command above doesn't work, I'm afraid you'll have to use the UI to import the data and save a project file.
我不记得3.6是否可以从命令行导入。它已经很老了。如果上面的命令不起作用,恐怕你得用用户界面来导入数据并保存一个项目文件。
头像
Nate

Nate
  • 帖子: 11350

ccwccy

非常感谢您的解答
ccwccy
  • 帖子: 2


回到 中国Spine用户