sh1

hello
I'm new to Spine.
when I try to start spine on Ubuntu, raise error and shown messeage.
"unexpect error"

from spine.log, it seems problem of java versions?

os version
Distributor ID: Ubuntu
Description: Ubuntu 16.04.3 LTS
Release: 16.04
Codename: xenial
附件
spine.log
(1.77 KiB) 被下载 70 次
sh1
帖子: 7

Nate

Sorry you are having trouble. We aren't able to reproduce this problem. Can you please try downloading and reinstalling Spine? We've updated the launcher today and that could be the difference.
头像
Nate

Nate
帖子: 7647

sh1

thank you for reply.
I tried to install by new installer and got same result .

I have 3 PC installed linux, so I tried at another linux PC, then install succeeded.
maybe, any dependencies ( ex. graphics driver ) or corrupted setting caused this.
I should do clean install ubuntu to 1st objective but currently I have no time.
for a while , I will use spine at this enviornment.
sh1
帖子: 7

Nate

Can you please post your spine.log from after you reinstalled Spine on the machine where Spine fails to load?
头像
Nate

Nate
帖子: 7647

sh1

ok.
附件
spine.log
(1.76 KiB) 被下载 66 次
sh1
帖子: 7

Nate

Thanks. It's very strange, I don't see how it could crash at that location unless something has modified Spine's files. That it works on a different machine also indicates something has modified Spine's files on the problematic machine, as unlikely as that seems. Maybe you have some antivirus or anti-malware software running?
头像
Nate

Nate
帖子: 7647

sh1

on problematic machine, I have installed antivirus software "clamTk". ( on different machine not installed)
so I removed clamTk then extract Spine and try to launch,but failed.
sh1
帖子: 7

Nate

Hmm, did you download Spine again after disabling the antivirus? Some of those nasty programs will modify things even inside an archive.
头像
Nate

Nate
帖子: 7647

sh1

yes, I did as you say.
in addition,
I imagine how spine trial and spine 32 bit version works, so I tried but all failed to launch.
sh1
帖子: 7

Nate

Very strange. Thanks for trying so many ways to get it to run. I'm afraid I'm at a loss as to why it would crash in this way. :(
头像
Nate

Nate
帖子: 7647

sh1

log message is different from ESS version
this is ~/.spinetrial/spine.log
OpenGL issue?
附件
spine.log
(2.68 KiB) 被下载 63 次
sh1
帖子: 7

Nate

Error initializing the OpenGL display. Please note libxrandr is required.
Yes, the trial is definitely complaining the libxrandr is needed. After more digging and with the knowledge the trial gives that error and so ESS should too, we were able to find the problem! Aha! It has been fixed in 3.6.44. Thank you for sticking with us and providing the information needed to figure it out! Cheers! :happy: :beer:

---

BTW, one way to install xrandr is:
sudo apt-get update
sudo apt-get install x11-xserver-utils
头像
Nate

Nate
帖子: 7647

sh1

OK , I succeeded!
I have noticed error message of trial version early on, but I do wrong way to install xrandr, as "apt-get install libxrandr-dev".
this is solved.

thank you for effort (^^b
sh1
帖子: 7

Nate

Great! We will put sudo apt-get install x11-xserver-utils right in the error message to make it clear. :)
头像
Nate

Nate
帖子: 7647


回到 Bugs