joker0720

Sometimes I get this, and sometimes I don't, so I'm unsure what I'm doing different.
I have all the images where they should be (thank you Photoshop script), and the bones where I want them. Now, it comes to link them together, so that when I move the bone, it moves the image.
So, I select the image, then I hit 'P' and select the bone. Sometimes it says I am creating an attachment, sometimes it just parents. I'm obviously doing something wrong, but I have no idea what that something wrong is.
Here is screen cap of the hierarchy of a character that did the 'attachment' thing to me. I'm BRAND new so, I'm stumped as to what is going on. I watched and followed along with an official video posted by Esoteric, and I'm not getting the same thing that she did. Two images, for the two sections of the hierarchy(both are under my 'root'):
Capture.PNG

Capture2.PNG

:bang: :bang: :bang: :bang: :bang: :angry:
EDIT: Also note that the 'skins' section no longer hides and unhides my skin, so I must have changed the images from a skin to an attachment, somehow.
头像
joker0720
帖子: 13

Erikari

Hello joker0720, welcome on the forum!
When you get asked to create a new slot after pressing P it's because you selected the attachment instead of the slot. If you filter the tree on slots, the filter will make sure that even if you select images in the viewport, slots will be selected. Without the filter, if you click on the images you see, the attachments will be selected, causing what you experienced. Basic Concepts - Spine User Guide and Tree - Spine User Guide: Filters have more details on this.

In the process of moving the attachments, you might have taken them out of their skin placeholders, which were the elements that hid the parts in a skin. just put them back inside the skin placeholders or create new ones by selecting all of the attachments you want to be in the skin, then in the tree click new>skin placeholder.
Skins - Spine User Guide
头像
Erikari

Erikari
帖子: 1292

joker0720

Erikari 写道:Hello joker0720, welcome on the forum!
When you get asked to create a new slot after pressing P it's because you selected the attachment instead of the slot. If you filter the tree on slots, the filter will make sure that even if you select images in the viewport, slots will be selected. Without the filter, if you click on the images you see, the attachments will be selected, causing what you experienced. Basic Concepts - Spine User Guide and Tree - Spine User Guide: Filters have more details on this.

In the process of moving the attachments, you might have taken them out of their skin placeholders, which were the elements that hid the parts in a skin. just put them back inside the skin placeholders or create new ones by selecting all of the attachments you want to be in the skin, then in the tree click new>skin placeholder.
Skins - Spine User Guide
I've read and watched those videos before. I was following along with a Spine Twitch video that went from asset creation through rigging, and animation, and somehow that is when I messed it all up. I'm trying to understand your second paragraph here, but I cannot seem to figure out how to do it in Spine. Also, would creating a new skin placeholder mess up all the other skins that will eventually be in this file? I really wish I had an older version of the file, so I could just start the attaching images to bones, again. Now I'm scared I have to start it over.

Think you could dumb down the steps to removing all those attachments and putting it back to before I started to connect the images to the bones? When I try to just move the images back to the attachments, it moves them all to origin, instead of staying where they were.
3D animator trying to wrap my brain around 2D. Don't mind me while I bash my head against the wall.
头像
joker0720
帖子: 13

Erikari

Regarding your regret/wish to have an older version of your Spine files, you'll be happy to know Spine automatically saves backups, just go to the spine settings until you find a folder icon that will open the folder where Spine saved the backups on your computer. Settings - Spine User Guide: General
joker0720 写道:would creating a new skin placeholder mess up all the other skins that will eventually be in this file?
No, it shouldn't cause problems.
joker0720 写道:When I try to just move the images back to the attachments, it moves them all to origin, instead of staying where they were.
This is because you're selecting the attachments instead of the slots. if you move the slots this doesn't happen.

I'll explain this briefly to dissipate doubts, when you create a skin:
- you'll have a new skin in the skin lists
- attachments that are not in skin placeholders will be visible across all skins
- when you create a skin placeholder, it will first be empty. If you move an attachment inside it, then change skin, the attachment will magically vanish until you activate the first skin again
- which means that a skin attachment may look empty in the current skin, but have attachments inside in other skins, so pay attention to this
- you can quickly change skins by pressing , and .
joker0720 写道:Think you could dumb down the steps to removing all those attachments and putting it back to before I started to connect the images to the bones?
The easiest way is probably restarting from the photoshop json/a backup, otherwise you should just pay attention to:
- if you're moving an image attachment around, place it inside a slot and not under a bone, this will avoid it being placed on the origin.
- if you're moving slots around, you shouldn't have major problems.
- get rid of the empty slots and/or skin placeholders, but make sure they're empty in all skins and not just the one you have active at the moment.

I think I covered your questions, but let me know if you have more doubts, and I'm happy to hear you were watching the streams :D were you watching the dudes?
头像
Erikari

Erikari
帖子: 1292

joker0720

Thank you for all the help! Since the character is pretty simple, I ended up just starting from scratch. I made sure to have the 'slots' filter selected when I ended up reattaching the images to the bones.
It all seems to be working now, but man if that wasn't a pain in the rear. Thanks again so much!
"Watching the dudes?" I was watching a young french (?) woman create assets, rig, and animate two cute characters. It's a part of Esoteric's youtube channel.
Thanks again! I'm sure I'll be back with many more newbie questions and problems.
3D animator trying to wrap my brain around 2D. Don't mind me while I bash my head against the wall.
头像
joker0720
帖子: 13

Erikari

Glad to hear everything is working now! Starting out takes always some time to figure out how things work, for me this video playlist was a huge help too: Spine User Guide - YouTube

You're right, I should have been more specific, I meant this series:

The dudes is the name of the project file, if this is the person you were referring, then it's me! (but I'm half Italian and half Polish, so if my accent is not so easy to identify it's good!) I'll be glad to also show things in Spine during live Twitch streams next time you have doubts (: https://www.twitch.tv/esotericsoftware
头像
Erikari

Erikari
帖子: 1292


回到 Editor