Palmdise

我们使用了lwrp渲染器和Spine。


在该渲染器下,要想正常显示SkeletonAnimation,只能使用Unity默认的Shader:Universal Render Pipeline/2D/Sprite-Lit-Default,但Alpha渐变会发黑。


SkeletonGraphic可以正常使用,前提是导出需要勾选Premultiply Alpha而不是Bleed。


所以请官方回复下,在lwrp渲染器下,如何才能使SkeletonAnimation Alpha渐变不发黑?


需要的话我们提供Demo工程。


谢谢~
Palmdise
  • 帖子: 3

Harald

我不确定我是否正确理解您的问题,因为机器翻译似乎无法正确翻译某些部分。

您是否在 straight alpha 工作流程中导出了骨架,在 Spine Export 中启用了 Bleed,在 Unity 的 Texture Importer 设置中启用了 sRGB Color TextureAlpha is Transparency,如下所示:
spine-unity Runtime Documentation: Advanced Premultiplied vs Straight Alpha Import

还请在 Inspector 的 SkeletonAnimation 组件中禁用 Advanced - PMA Vertex Colors
-----
I'm not sure I understand your question correctly, as machine translation seems to have failed translating some parts properly.

Did you export your skeleton in straight alpha workflow, having Bleed enabled in Spine Export and sRGB Color Texture and Alpha is Transparency enabled in Unity's Texture Importer settings, as shown here:
spine-unity Runtime Documentation: Advanced Premultiplied vs Straight Alpha Import

Please also disable Advanced - PMA Vertex Colors at the SkeletonAnimation component in the Inspector.
头像
Harald

Harri
  • 帖子: 3353


回到 中国Spine用户